TrueCrypt v7.1a launch error ‘TrueCrypt is already running’

I’m running kali linux on a regular pc and i have TrueCrypt v7.1a installed .

I used it for quite a while w/o any problems at all. Recently, it’s developed a glitch in the start-up. When I click on the launcher in the menu, the result is a dialogue box popping up in screen center with the message “TrueCrypt is already running.”.

This is despite there being no TrueCrypt icon on the panel, and no TrueCrypt process running in the list. I could boot the computer, start a Gnome session, immediately try to use TrueCrypt – and, the result is the same.

There was no problem uninstalling.
I rebooted, & reinstalled TrueCrypt v7.1a. When I tried to use it, the same disfunction happened as during the previous installation of the program – the “TrueCrypt is already running” error dialogue box.

The Solution for this problem

This error is typically caused if you abruptly shutdown your Linux, without giving TrueCrypt the chance to close properly.

Just delete the file named .truecrypt_lock  (.truecrypt_lock-profilename.) in your Home folder. It’s a hidden file so you need to press CTRL+H in order to see it.

When searching, replace profilename w/ whatever Linux session user name is in use for the Gnome session; i.e., same as the home directory.

 

WARNING: Using TrueCrypt is not secure as it may contain unfixed security issues

The development of TrueCrypt was ended in 5/2014 after Microsoft terminated support of Windows XP. Windows 8/7/Vista and later offer integrated support for encrypted disks and virtual disk images. Such integrated support is also available on other platforms (click here for more information). You should migrate any data encrypted by TrueCrypt to encrypted disks or virtual disk images supported on your platform.

To download TrueCrypt click here

Everything should be fine again.

Good luck.